Service Alert - WileyPLUS Service Interruption

Incident Report for WileyPLUS

Resolved

This incident has been resolved.
Posted Jun 12, 2025 - 16:53 EDT

Update

We are continuing to work on a fix for this issue.
Posted Jun 12, 2025 - 16:53 EDT

Identified

We apologize for the inconvenience, but due to an ongoing issue with Cloudflare, users of WileyPLUS may not be able to see all image or video content. We are working to resolve the issue as soon as possible. Please check back for updates.
Posted Jun 12, 2025 - 16:09 EDT
This incident affected: WileyPLUS.