New WileyPLUS - Reports of Slowness
Incident Report for WileyPLUS
Resolved
This incident has been resolved.
Posted Nov 12, 2020 - 15:20 EST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Nov 12, 2020 - 15:12 EST
Identified
The issue has been identified and a fix is being implemented.
Posted Nov 12, 2020 - 15:07 EST
Investigating
We have received reports that New WileyPLUS is running a little slowly for some users. This has resulted in longer page load-times, and sometimes an error message. We are investigating the issue. We apologize for any inconvenience this may cause. Please check back for updates.
Posted Nov 12, 2020 - 14:54 EST
This incident affected: WileyPLUS (next generation).