We are pleased to report that the previous issues WileyPLUS was experiencing have been resolved. We apologize for any inconvenience you may have experienced as a result. If you need any technical assistance please reach out to our Technical Support team. Please consider, for any subsequent platform status updates, subscribe to our SMS message service. To review WileyPLUS platform status at anytime, please visit http://status.wileyplus.com.
Posted Nov 18, 2025 - 10:16 EST
Monitoring
The issue previously reported appears to be resolved by Cloudflare and all sites are returning to normal. They and we continue to monitor and will update this page with any change in status.
Posted Nov 18, 2025 - 10:01 EST
Identified
We are currently experiencing a service interruption. Some customers are unable to access the platform, and all are unable to access our eBook content. This is due to an outage with a major internet content delivery service (Cloudflare). We apologize for this inconvenience. Please check back for updates.