Service Alert - WileyReader Issue
Incident Report for WileyPLUS
Resolved
We are pleased to report that the previous issues with the WileyReader have been resolved. We apologize for any inconvenience you may have experienced as a result. You may need to clear your cache or restart your browser for the pages to load correctly. If you need any technical assistance please reach out to our Technical Support team.

Please consider, for any subsequent platform status updates, subscribe to our SMS message service. To review WileyPLUS platform status at anytime, please visit http://status.wileyplus.com.
Posted Jun 13, 2023 - 16:46 EDT
Update
We continue to experience technical difficulties that will effect customer access to Wiley Reader and the WileyPLUS e-textbook. We are working with Amazon to resolve the issue and we will keep you updated. Thank you for your patience. We apologize for any inconvenience this may cause.
Posted Jun 13, 2023 - 16:30 EDT
Identified
We are currently experiencing a problem that may affect access to WileyReader or your e-textbook in WileyPLUS. We are investigating the issue. We apologize for any inconvenience this may cause. Please check back for updates.
Posted Jun 13, 2023 - 15:41 EDT
This incident affected: WileyPLUS.