Service Alert - WileyPLUS assignments
Incident Report for WileyPLUS
Resolved
This incident has been resolved.
Posted Mar 21, 2022 - 12:37 EDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Mar 21, 2022 - 12:34 EDT
Investigating
We are currently experiencing a problem with the WileyPLUS Assessment Service. We are investigating the issue. We apologize for any inconvenience this may cause. Please check back for updates.
Posted Mar 21, 2022 - 12:01 EDT