Service Alert - WileyPLUS Outage

Incident Report for WileyPLUS

Resolved

An issue with log in was reported, identified and quickly resolved by our internal IT team. We apologize for any inconvenience caused.
Posted Sep 24, 2026 - 07:34 EDT

Investigating

We are currently receiving reports of multiple failed log-in attempts on wileyplus.com. We are investigating and will post further updates once additional information is available. We apologize for any inconveniences this may be causing.
Posted Sep 24, 2026 - 07:23 EDT
This incident affected: WileyPLUS.