Service Alert - WileyPLUS Assessment Issue
Incident Report for WileyPLUS
Resolved
We are pleased to report that the previous issues WileyPLUS was experiencing have been resolved. We apologize for any inconvenience you may have experienced as a result. If you need any technical assistance please reach out to our Technical Support team. Please consider, for any subsequent platform status updates, subscribe to our SMS message service. To review WileyPLUS platform status at anytime, please visit http://status.wileyplus.com.
Posted May 02, 2021 - 23:32 EDT
Investigating
We are currently experiencing a problem with the assignment section of WileyPLUS. We are investigating the issue. We apologize for any inconvenience this may cause. Please check back for updates.
Posted May 02, 2021 - 23:17 EDT