Service Alert – WileyPLUS Outage

Incident Report for WileyPLUS

Resolved

This incident has been resolved.
Posted May 08, 2026 - 07:38 EDT

Update

Due to an ongoing incident with Canvas, we are currently experiencing an issue affecting WileyPLUS access through Canvas and direct (non-LMS) access. Users accessing WileyPLUS through any other LMS are not affected and can now use the platform as normal.
Posted May 07, 2026 - 19:06 EDT

Update

We are continuing to investigate this issue.
Posted May 07, 2026 - 17:39 EDT

Investigating

We continue to investigate a service interruption. We will provide additional updates as they become available. We apologize for this inconvenience.
Posted May 07, 2026 - 16:27 EDT
This incident affected: WileyPLUS.