Registration Impaired
Incident Report for WileyPLUS
Resolved
Registration page now is up.
Posted 10 months ago. Apr 17, 2017 - 04:07 EDT
Investigating
We are currently experiencing some problems in our registration system. We are working on the issue and expect it to be up and running shortly.  Please check back in for updates on our progress. Thank you for your patience.
Posted 10 months ago. Apr 17, 2017 - 03:38 EDT
This incident affected: WileyPLUS Platform.