Technical Difficulties with Integrations
Incident Report for WileyPLUS
Resolved
We are pleased to report that the previous issues WileyPLUS was experiencing have been resolved. We apologize for any inconvenience.
Posted 4 months ago. Jul 22, 2018 - 21:15 EDT
Investigating
We currently experiencing a technical issue that may affect ORION Adaptive practice or the way you access your WileyPLUS course. We are working to resolve this issue as soon as possible. Please signup for our email and SMS message service, and we will notify you when WileyPLUS is back online.
Posted 4 months ago. Jul 22, 2018 - 20:56 EDT
This incident affected: WileyPLUS.