ATTENTION – POSSIBLE SYSTEM SLOWNESS
Incident Report for WileyPLUS
Resolved
The system slowness some WileyPLUS customers experienced earlier has been resolved. Thank you for your patience.  If you need technical assistance, please reach out to our Technical Support team.  For future platform status updates, subscribe to our text message service. To review WileyPLUS platform status at anytime, please visit http://status.wileyplus.com.
Posted over 1 year ago. Jul 26, 2017 - 21:41 EDT
Identified
Some WileyPLUS customers are experiencing slowness within the platform. We are working to resolve this issue.
You can sign up for our text message service at http://status.wileyplus.com, and we will text you when the system slowness has been resolved.  To review WileyPLUS platform status at anytime, please visit http://status.wileyplus.com.
Posted over 1 year ago. Jul 26, 2017 - 19:37 EDT
Investigating
We are currently tracking system slowness for some WileyPLUS customers. We are working to resolve this issue.
Posted over 1 year ago. Jul 26, 2017 - 19:19 EDT
This incident affected: WileyPLUS.