System Slowness
Incident Report for WileyPLUS
Resolved
This incident has been resolved.
Posted 5 months ago. Sep 12, 2017 - 07:15 EDT
Identified
Some WileyPLUS customers are experiencing slowness within the platform. We are working to resolve this issue.
You can sign up for our text message service at http://status.wileyplus.com, and we will text you when the system slowness has been resolved.  To review WileyPLUS platform status at anytime, please visit http://status.wileyplus.com.
Posted 5 months ago. Sep 11, 2017 - 20:37 EDT
Investigating
We are currently tracking system slowness for some WileyPLUS customers. We are working to resolve this issue.
Posted 5 months ago. Sep 11, 2017 - 20:08 EDT
This incident affected: WileyPLUS Platform.