Registration Impaired
Incident Report for WileyPLUS
Resolved
The earlier technical issue with WileyPLUS has been resolved. We’re sorry for any inconvenience you may have experienced as a result. To review WileyPLUS platform status at anytime, please visit http://status.wileyplus.com.
Posted over 1 year ago. Apr 18, 2017 - 14:12 EDT
Identified
We are continuing to experience problems in processing registrations. We  are continuing to work on resolving the issue. We appreciate your patience.
Posted over 1 year ago. Apr 18, 2017 - 13:31 EDT
Investigating
We are currently experiencing some problems in our registration system. We are working on the issue and expect it to be up and running shortly.  Please check back in for updates on our progress. Thank you for your patience.
Posted over 1 year ago. Apr 18, 2017 - 13:02 EDT
This incident affected: WileyPLUS.