Service Alert
Incident Report for WileyPLUS
Resolved
We are pleased to report that the previous issues WileyPLUS was experiencing have been resolved. We apologize for any inconvenience you may have experienced as a result. If you need any technical assistance please reach out to our Technical Support team. Please consider  For any subsequent platform status updates, subscribe to our SMS message service. To review WileyPLUS platform status at anytime, please visit http://status.wileyplus.com.
Posted 9 months ago. Jan 09, 2018 - 19:04 EST
Identified
WileyPLUS is currently experiencing a technical issue and is unavailable to customers. We apologize for this inconvenience. We are working to resolve this issue as soon as possible and will email you when the issue
Posted 9 months ago. Jan 09, 2018 - 18:46 EST
Investigating
We apologize for this inconvenience, but WileyPLUS is currently unavailable due to technical issues. We are working to resolve this issue as soon as possible. Want updates? Sign up for WileyPLUS email and text notifications at http://status.wileyplus.com.
Posted 9 months ago. Jan 09, 2018 - 18:18 EST
This incident affected: WileyPLUS.