Registration Impaired
Incident Report for WileyPLUS
Resolved
The earlier technical issue with WileyPLUS has been resolved. We’re sorry for any inconvenience you may have experienced as a result. To review WileyPLUS platform status at anytime, please visit http://status.wileyplus.com.
Posted 11 months ago. Jan 20, 2018 - 20:53 EST
Identified
We are currently experiencing some problems in our registration system. We are working on the issue and expect it to be up and running shortly.  Please check back in for updates on our progress. Thank you for your patience.
Posted 11 months ago. Jan 20, 2018 - 15:01 EST
This incident affected: WileyPLUS.