Service Alert
Incident Report for WileyPLUS
Resolved
This incident has been resolved.
Posted 3 months ago. Aug 16, 2018 - 16:20 EDT
Update
We apologize for this inconvenience, but our WileyPLUS catalog is currently unavailable due to technical issues, but users are still able to log in to the site.

If you're a WileyPLUS user, please go here: https://www.wileyplus.com/WileyCDA/
If you're a WileyPLUS (next generation) user, please go here: https://www.wileyplus.com/go/login

We are working to resolve this issue as soon as possible.

Want updates? Sign up for WileyPLUS email and text notifications at http://status.wileyplus.com.
Posted 3 months ago. Aug 16, 2018 - 15:43 EDT
Update
We are continuing to investigate this issue.
Posted 3 months ago. Aug 16, 2018 - 15:41 EDT
Investigating
We apologize for this inconvenience, but our WileyPLUS catalog is currently unavailable due to technical issues, but users are still able to log in to the site.

If you're a WileyPLUS user, please go here: https://www.wileyplus.com/WileyCDA/
If you're a WileyPLUS (next generation) user, please go here: https://www.wileyplus.com/go/login

We are working to resolve this issue as soon as possible.

Want updates? Sign up for WileyPLUS email and text notifications at http://status.wileyplus.com.
Posted 3 months ago. Aug 16, 2018 - 15:27 EDT
This incident affected: WileyPLUS.